Error Dialog: Fehler beim Speichern / OneDrive One Drive


My AuthPass DB is stored on my OneDrive personal cloud storage (from beginning - same years ago). Today I wanted to add a new entry, but after saving the following error occurred. Last succesfully saving/changing was two weeks ago.

I tried

  • closing the DB,
  • logged off from microsoft/OneDrive (and on again),
  • reboot my iPhone (iOS17.4.1; latest AuthPass-App-Version)
  • tried editing an existing entry (same error)
  • clicked „reload and put together“ (neu laden und zusammenführen / I have german Language settings)

Can anyone please help me solving the problem?

Greetings, Bert

title:Fehler beim Speichern
content: Datei konnte nicht gespeichert werden: StorageException{type: StorageExceptionType.conflict, details: Conflict while uploading to One Drive., errorBody: {“error”:{“code”:“notAllowed”,“message”:“ETag does not match current item’s value”,“innerError”:{“date”:“2024-04-18T19:16:05”,“request-id”:“057c41bf-95e7-4a1a-916f-61950aa8512b”,“client-request-id”:“057c41bf-95e7-4a1a-916f-61950aa8512b”}}}}
OS: ios Version 17.4.1 (Build 21E236)
App Info: AuthPass (1.9.11+2007) [design.codeux.authpass.ios]
Device: {name: iPhone, model: iPhone, systemName: iOS, systemVersion: 17.4.1, localizedModel: iPhone, utsname: {release: 23.4.0, sysname: Darwin, nodename: localhost, machine: iPhone14,3, version: Darwin Kernel Version 23.4.0: Fri Mar 8 23:31:19 PST 2024; root:xnu-10063.102.14~67/RELEASE_ARM64_T8110}}

I made more tries to solve my obove described problem, but no fix. What I did:

  • delete and reinstall the Authpass app
  • delete the app-rights within my microsoft-account, than grand access again while opening my keepass-file on OneDrive
  • create a new local database (with Authpass-App on iPhone) and in step 2 tried to transfer it to Onedrive within the app. This leads to the following error.

I finally tried to gain OneDrive access to a completly different app and - not totally proven - but perhaps there is also a problem editing/writing files. So maybe it is an iOS 17.4.1 problem?!?

Log file for AppInfo {
} (ios)

title: Error while Speichere
content: Null check operator used on a null value
====================Available Log Files:
/var/mobile/Containers/Data/Application/415B22FC-1DFE-4A4B-8AD5-9883D762042B/Library/Caches/logs/app.log.txt: FileStat: type file
changed 2024-04-19 06:11:10.913
modified 2024-04-19 06:11:10.913
accessed 2024-04-19 00:29:36.604
mode rw-r–r–
size 4298409