Invalid arguments(s): Invalid or corrupted pad block

Hello everyone,

I’m unable to login into my kdbx file. I know I’m using the right password, because when I insert a wrong one I get the specific error that password is wrong.
However when inserting correct password the following error message shows up: “Unknown error while trying to open file. Invalid arguments(s): Invalid or corrupted pad block.”

I can’t send the Error report because nothing happens when clicking on it and the only option left is to ask help here.
I read in a similar topic to try and access it using the AuthPass Dev app, but that didn’t help also.

I tried also to delete app cache and reinstall it, still nothing helped.

I’m on Android 11, Oxygen OS
Could you please help me out here?

how did you create / last modify the kdbx file? Was it using AuthPass? If not, can you still open it with another keepass app?

Is it possible you don’t have a (default) email app installed?

Hey Herbert,

I created it using AuthPass and used it only with this app. I haven’t tried other apps since I wasn’t sure if I will be able to have all my passwords inside etc.

Regarding email app, this is not possible since I have Outlook and Gmail installed and using them.

The kdbx file format should be fully compatible with all clients. Maybe you could give it a try to see if the file is corrupted somehow, or it’s a bug in AuthPass. Up until know I have only seen this with users who created the file with another password manager and it was resolved by switching to kdbx 4. I assume there might be a bug in the AES decryption (while kdbx 4 uses chacha20 by default).

You can for example try to use keeweb which doesn’t require an installation (and runs completely client side, so it won’t leak data).

That’s weird. Can you try if you are able to access the log file? When you go into the about dialog and scroll to the bottom it will show the full path.

Btw, I have never been able to reproduce this problem. So if you can somehow recreate that scenario with a password file you can share, that would be awesome.


I tried to open the file using the keeweb app but it didn’t want to unlock. I tried and downloaded Keepass2Android Password Safe and that app opened the file without any issue.

I reached the folder but it was empty, so it seems that no report/log file was created. Same this goes for the Dev version of the app.

I tried to create new database but this one doesn’t have problems with access.

just to make sure, you are certain that you have never before accessed/saved this password file with another client?

I can’t quite imagine how no log file was created, i’ve never encountered that problem. Either it is related to Oxygen OS, or maybe the file is located in the apps sandbox and shows you the wrong location. :thinking:

I’m not 100% sure I’ve used just this app, since before that I was trying some other apps. But if I remember correctly, I created database with AuthPass.

I really don’t know, when clicking on the Send Error Report really nothing happens, like the button doesn’t have an action.

In this case it depends on which client you last used to save/encrypt the file. It would be really interesting to see if it was reproducible. Since it’s a padding problem it could be very much a problem which only occurs sparingly. (e.g. it could only occur when the encrypted data is a multiple of 16 bytes).

btw. You said that you also had an error when trying to open with keeweb - do you remember what the error message was?

I have used this file only with AuthPass and updated it with the app. I really don’t know how should I reproduce the same error.

When trying to open with there’s no actual error, but the login field becomes red as if the password is wrong. I’m sure the password is correct since it is opening by using the other app I stated before.

Now I’m confused, sorry. Previously you said you were not sure, because you tried out other apps :thinking:

anyway, have you tried resaving the file with keepass2android, if you are able to open it with AuthPass afterwards?
In case this does not work, maybe you could try to use Keepass2Android to go into the “Database Settings” and set the ‘Algorithm’ from AES to ChaCha20 - this should get rid of that error for good.

1 Like

I tried out some apps before AuthPass, but after I started using AuthPass I didn’t try any other and I was just not sure if the kdbx file was from before or I actually created it in AuthPass. Hope it’s clearer.

This actually solved the issue!

Thank you for your patience and your help. :slightly_smiling_face:
I really don’t know what was happening there.

Great to hear, thanks for trying it out.

Although it would also be nice to somehow be able to reproduce that error :grimacing: if you have any ideas, let me know.

1 Like