iOS Install on iPhone & iPad load from Dropbox, wont allow second device to connect

Version: iOS AuthPass 1.9.9

I have tried to find this in the forums but have not found anything relating to it so I apologise now if its a copy.

I trying to help an older friend but have failed…

We have an iPhone 15 with iOS 17 and an older iPad on iOS 16.
I have installed Authpass on the phone and manged to load from dropbox, authenticated and allowed it so it generates its app token.
it came back and I successfully selected my password file and it worked.

I then went to my iPad and did the same thing.
Load from dropbox, logged in using the same dropbox account as my phone.
However it will not allow access to the dropbox file.

Sometimes I get a message the file is already open but none of keypass apps are running on any device.
Other times it refuses to list any files to select.

I foolishly then went to my dropbox and deleted the token, thinking it’ll allow me to start again.
But neither device now shows the allow button when authenticating with dropbox, it just returns to the cloud storage with the search box and no files ever show up.

The first time this happened I removed the app from the iPhone and its data.
Cleared the AuthPass app token from dropbox.
That did allow me to connect, allow and use my keypass database.
Which works for a month on its own, but then looses access to dropbox and I seem to have to go through this pain all over again.

I only use the app on a singe device at any one time.

So my main question is:
Am I able to use AuthPass on two iOS devices accessing from the same dropbox account (but not at the same time)?

The second issue; is the iPhone was working but after a month seems to loose access to dropbox.
Which is why am having to keep deleting the DropBox Authpass app token and start again.
Is there any reason why my iPhone keeps loosing the ability to access dropbox, hence i keep having to reconnect it?

Thanks for any advice

I have the solution to this problem now.

Turns out my friend has a free Dropbox account.
His dropbox account already had 3 devices linked which is the maximum for the free account.
So upon trying to connect his iPad (4th device) it just returned with no errors or reason.

I didn’t realise he already had 3 devices connected as I was helping him over the phone.

Anyway if you experience where you load from dropbox, login and don’t get an allow button or after authorising you get no files listed, check your dropbox account for the number of connected devices.