Issuues with keyfile

I tried to open existing base with keyfile and always get an error that password is wrong.
It successfully can be opened by keepas 2.
I generate new base with new keyfile and get the same error.
Is it possible to open such bases in authpass?

Yes that should work actually. Can you create a new dummy kdbx file with a keyfile you could share, so I can reproduce your problem?

Hi. Password is “qwe”
It does not work neither iOS nor Windows10



Do you need additional information?

The problem was that “version 2” keyfiles weren’t supported at all. I’ve now implemented it. Maybe you can try the latest windows build:

thanks, Herbert

fyi, i’ve now also published a beta version to testflight: if you want to test it on iOS as well.

Thx, man!
It works. I’ll try it on ios a little bit later.
You are doing a great job.
PS. I thought, that v2 is the main standard of kbdx files today…

v2 keyfile format, not kdbx format. (which you were using 3.x, while the “current” is 4)

Ahh! I see. I thought about kbdx, but you were taking about keyx.
And I thought kbd is 1st version, and kbdx is 2nd.
Thx again for your reply