Master password and biometric on existing kdbx

Test steps:

  • Register fingerprint with lineage is 18.1
  • open existing kdbx with master password
  • check safe storage with biometrics

Expected result:
Fingerprint is accepted

Actual result:
See error message below

Work around:
Unchecked biometrics and open kdbx with master password alone

Please help me out here!

Best regards and keep up the good work

title:Datei kann nicht geöffnet werden
content: Unbekannter Fehler beim Öffnen der Datei. PlatformException(Unexpected Error, Key permanently invalidated, Key permanently invalidated Key permanently invalidated
at javax.crypto.Cipher.tryTransformWithProvider(
at javax.crypto.Cipher.tryCombinations(
at javax.crypto.Cipher$SpiAndProviderUpdater.updateAndGetSpiAndProvider(
at javax.crypto.Cipher.chooseProvider(
at javax.crypto.Cipher.init(
at javax.crypto.Cipher.init(
at design.codeux.biometric_storage.j.g(Unknown Source:14)
at design.codeux.biometric_storage.c.f(Unknown Source:4)
at design.codeux.biometric_storage.e.r(Unknown Source:52)
at design.codeux.biometric_storage.e.h(Unknown Source:0)
at design.codeux.biometric_storage.e$m.a(Unknown Source:21)
at design.codeux.biometric_storage.e$m.c(Unknown Source:2)
at design.codeux.biometric_storage.e.s(Unknown Source:19)
at design.codeux.biometric_storage.e.n(Unknown Source:132)
at i.b.c.a.j$a.a(Unknown Source:17)
at io.flutter.embedding.engine.f.b.e(Unknown Source:49)
at io.flutter.embedding.engine.FlutterJNI.handlePlatformMessage(Unknown Source:4)
at android.os.MessageQueue.nativePollOnce(Native Method)
at android.os.Looper.loop(
at java.lang.reflect.Method.invoke(Native Method)
, null)
OS: android lineage_oneplus3-userdebug 11 RQ3A.210805.001.A1 a0cb304b32
App Info: AuthPass (1.9.3+158) [design.codeux.authpass.fdroid]
Device: {id: RQ3A.210805.001.A1, tags: release-keys, type: userdebug, model: ONEPLUS A3003, board: msm8996, brand: OnePlus, device: OnePlus3, product: lineage_oneplus3, display: lineage_oneplus3-userdebug 11 RQ3A.210805.001.A1 a0cb304b32, hardware: qcom, version: {baseOS: , sdkInt: 30, release: 11, codename: REL, incremental: a0cb304b32, previewSdkInt: 0, securityPatch: 2021-08-05}, manufacturer: OnePlus, isPhysicalDevice: true}

Can you please clean the biometric storage as described in: Error while Error retrieving item. -25291: -25291: No keychain is available. You may need to restart your computer and then try again?

This can happen when you add/remove fingerprints or change security settings. (Or due to a number of strange bugs…)

I am on Android not iOS.

Same error after clearing biometrics…

No luck with clearing app cache.

app cache or app data? btw. you can also try the latest beta version which should contain a few fixes, including a fix to the “clear biometrics”

Great job: development beta solved the issue for me!

Thanks a lot!

1 Like