OAuth2 Credentials expired (Dropbox storage)

macOS Monterey 12.4.

Installed AuthPass and opened existing DB file stored in Dropbox (using the built-in Dropbox auth).

Several hours later I re-opened AuthPass and got the error popup: “Error while saving
Unable to save file: OAuth2 credentials have expired and can’t be refreshed.

Same error if I try to save the open DB file.

If I change the DB open method to just use the locally stored file in the Dropbox folder, it works fine.

What is the problem, please? Thanks, M.

Same here, in Android.
Any ideas for this!? Details see below.
/Alex

title:Fehler beim öffnen der Datei.
content: {type: FileSourceCloudStorage, uuid: bd05bedd-cf06-4d3a-ba0b-b15e6fdf2c8b, databaseName: AlexPasswords, displayPath: /AlexPasswords.kdbx} konnte nicht geöffnet werden.
OAuth2 credentials have expired and can’t be refreshed.
OS: android YT-X705F_S001135_210909_ROW
App Info: AuthPass (1.9.6+1904) [design.codeux.authpass]
Device: {id: QKQ1.191224.003, tags: release-keys, type: user, model: Lenovo YT-X705F, board: QC_Reference_Phone, brand: Lenovo, device: YT-X705F, product: YT-X705F_EEA, display: YT-X705F_S001135_210909_ROW, hardware: qcom, version: {baseOS: , sdkInt: 29, release: 10, codename: REL, incremental: X705F_S001135_210909_ROW, previewSdkInt: 0, securityPatch: 2021-09-05}, manufacturer: LENOVO, isPhysicalDevice: true}

Create Topiccancel

And same error again when running AuthPass on Windows 11 for the first time…

Can you click on the logout button in the top right and authenticate again?

OK. Did the logout & re-authenticate with Windows 11/Dropbox (works); then did the same with macOS/Dropbox (also works).

The first time I used AuthPass with Dropbox on macOS, I got the OAuth error the next day. If it’s OK I’ll confirm with you right here within 24 hours if the auth is still good.

Thanks!

After leaving my system overnight, I opened the macOS AuthPass. Sadly I get the same OAuth error again:

thanks for the update… It seems there was a change on how dropbox handles oauth. It by default no longer returns a refresh_token. I’ve fixed it now, maybe you can give it a try… I’ll probably make a new release soon’ish

https://data.authpass.app/data/artifacts/AuthPass.app-1.9.7_1933.zip or windows: https://data.authpass.app/data/artifacts/AuthPass-setup-1.9.7_1934.exe

also, while you are at it, maybe you could give that windows version a try to see whether opening of local files works for you? :slight_smile:

OK, the Windows version now opens local KDBX files just fine. I did notice that when I locked the file, the App closed (crashed?)

I set a new OAuth token for Dropbox on both platforms, so keep this open and I’ll report back in 24 hours.

Yep. The Dropbox auth is all fixed!

1 Like