So slow on Android: Fingerprint to opened file

I think the answer might be “too bad, so sad”, but I’ll ask anyway :slight_smile:

On the PC, I can open my kbdx file* with KeePassXC in a fraction of a second. I have “SyncTrazor / Sync Thing” so that the file is kept in sync between the PC and the Android Pixel 3a. I don’t use cloud anything. When I open it on AuthPass, it was taking 20+ seconds or so. This is the same whether SyncThing is on or off, so it’s not a file lock issue.

Because it was so slow, I thought I’d reduce the “encryption rounds”. I went into KeePassXC > Database > Database Security > Encryption Settings and it was originally set to “1.0 s”. I changed it to “500 ms” and it took even LONGER to open in AuthPass!! That was totally unexpected. So I changed it to “100 ms” (the shortest possible setting), and AuthPass is taking about 25 seconds from finger print acceptance to seeing the list.

So I’m not sure what’s going on here, and if there’s any way to get this working a bit more quickly.

  • My kdbx file has been around a very long time, and I’m lazy, so never really clean out the old stuff. As a result, it’s 126KB. Not sure the size of the file has a large effect or not.

ETA: Poking around in AuthPass, I found that the KDBX File Version was 4.1 (Cipher: aes, inner: chaCha20, Kdf: AES, rounds: 2678571). I changed the setting in KeePassXC from 100ms to 200ms, and the rounds went from 2678571 to 4651163 with an expected longer time required to open the file.

Well… yes, your smartphone is probably slower than your pc… but AES in AuthPass is particularly slow. You might try to change to Argon2… you should be able to do so in keepassx Security settings…